How to Identify which version of Sky Remote control you have

In order to use your Sky Remote Control to operate the TV's functions, you need to ensure you have the correct (or later) version of Sky Remote Control. On the code listing page for your TVs brand, it will inform you which version is necessary. If you do not have the correct version, the code will not be accepted by your Sky Remote.

(Sky determine which codes to include in which versions of their remote control, therefore, if you have an earlier version, the software/firmware inside the Sky remote will not include the code and therefore will not operate your TV.) It is not possible to upgrade a Sky Remote controls software/firmware.

  1. Remove the battery cover

  2. Either on the battery cover itself or below the batteries, you will see a label with various numbers/letters on it.

  3. At the end of the code, you will see the Sky Rev. number. (for example if it shows Sky Rev.8 or similar, this is a revision 8, if it says Sky Rev.9, this is a revision 9. Revision 9 is required in most cases. See picture of a typical label table below)

skyremotecode.gif