UMC (UK) LTD
Contact and Helpline info

 

How to Identify which version of Sky Remote control you have



In order to use your Sky remote control to operate the TV's functions, you need to ensure you have the correct  (or later) version of Sky remote control. On our code listings pages, it will inform you which version is necessary. If you do not have the correct version, the code will not be accepted by your sky remote (Sky determine which codes to include in which versions of their remote control, therefore, if you have an earlier version, the software/firmware inside the Sky remote will not include the code and therefore will not operate your TV.) It is not possible to upgrade a Sky Remote controls software/firmware.  

skyremotecode.gif




We accept the following methods of payment: We accept the following methods of payment

Copyright © 2017 UMC (UK) LTD.